What are the minimum browser requirements for Twilio Client?

Twilio Client for Browser (Flash)

The flash base supports Google Chrome 11+ (however, Flash is currently not compatible with Chrome incognito mode), Internet Explorer 7+, Safari 5+, and Firefox 3.6+ with Flash 10.1 or higher installed.

Tools

Test to see if your browser meets these requirements.

Twilio Client for Browser (WebRTC)

You must be using version 1.1 or later of Twilio Client with a browser which supports WebRTC.

Also see detailed network requirements for Twilio Client.