Skip to main content

Twilio Changelog

Additions and changes to the Twilio platform

Elastic SIP Trunking

Elastic SIP Trunking TLS v1.0/1.1 Deprecation

As per Internet Engineering Task Force (IETF) recommendations, Twilio strongly recommends the use of TLS version 1.2, and has deprecated default support for TLSv1.0 and TLS v1.1 when connecting your SIP Infrastructure to Twilio Elastic SIP Trunking.  If your infrastructure requires TLSv1.0 or TLSv1.1, you can configure your Twilio Account to allow these deprecated versions in your console under Voice → Settings → Allow Deprecated SIP/TLS versions.

In order to reduce service disruptions for existing customers, we have already applied this configuration to existing accounts that have used or provisioned SIP Domains and/or Elastic SIP Trunks. You can review the setting in your Twilio console, and disable the configuration, if your SIP server is already using TLSv1.2.  New accounts will not have this configuration applied, meaning that these accounts will be configured to use only TLSv1.2 by default. The ability to “Allow Deprecated SIP/TLS Versions” is available to these accounts, but if so, this configuration needs to be enabled in the account’s console.

For more information, see our documentation.