Minimum Web Browser Requirements for Twilio Client

Twilio Client for Browser (WebRTC)

You must be using version 1.1 or later of Twilio Client with a browser which supports WebRTC. The most recent version of Twilio Client is always recommended.

Twilio Client for Browser (Flash)

Twilio Client version 1.3 and later do not contain a Flash base. The Flash base included in Twilio Client version 1.2 supports:

  • Google Chrome 11+ (Chrome incognito mode not supported)
  • Internet Explorer 10 and greater
  • Safari 5 and greater
  • Firefox 3.6 and greater with Flash 10.1 or higher installed.

While these are the recommended browsers and versions for Twilio Client, you can verify that your browser is is properly configured by using the Twilio Client Support Tool. Also see our detailed network requirements for Twilio Client.