Android SDK

System Requirements

Supported Devices and Emulators

The Programmable Voice Android SDK supports armeabi-v7a, arm64-v8a, x86, and x86_64 architectures, as well as emulator images for these architectures.

Supported API Levels

The SDK supports Android API Level 16 (Jelly Bean) and higher.

Developer Tools

To build the associated Quickstart project you will need Android Studio with installed SDK Platform for API Level 24, as well as the supporting libraries.

Installing the SDK

To install the latest Programmable Voice Android SDK add the following configuration to your build.gradle file:

allprojects {
  repositories {
     jcenter()
  }
}

dependencies {
  // The Voice SDK resides on jCenter
  compile 'com.twilio:voice-android:2.0.0-beta1'
}

Enabling Microphone Permissions

In order to target Android API level 23 or later, you will need to ensure that your application requests runtime permissions for microphone access. To do this, perform the following two steps:

First, add the following to your Android Manifest file:

 <uses-permission android:name="android.permission.RECORD_AUDIO"/>

Second, request microphone permissions from within your application code:

ActivityCompat.requestPermissions(this,
    new String[]{Manifest.permission.RECORD_AUDIO}, MIC_PERMISSION_REQUEST_CODE);
}

See the Official Android Documentation for more details.

Setting up a ProGuard Exception

Add the following line to your proguard-project.txt file.

# Twilio Programmable Voice
-keep class com.twilio.** { *; }

This will ensure that the Programmable Voice library is not removed by ProGuard.